25. 10. 2006 v sekci prohlížeče:

Firefox 2.0 – raději počkejte

Mozilla Foundation vypustila do světa novou verzi mého oblíbeného prohlížeče – Firefox 2.0…

Mozilla Foundation vypustila do světa novou verzi mého oblíbeného prohlížeče – Firefox 2.0, kterou jsem si s nadšením nainstaloval hned, jak se objevila na FTP serverech. Teď bych se ovšem rád vrátil zpět.

Firefox 2.0 je rychlejší, vypadá lépe a má přítulnější uživatelské rozhraní, než Firefox 1.5. Leč kouzlo Firefoxu není ve vizuálním rozhraní, ale v rozšířeních. A právě většina rozšíření dosud není s dvojkovou verzí kompatibilní.

Takže se mi teď ani neukládají taby SessionSaverem, ani si nesejmu screen Screen Grabem – alespoň, že WebDeveloper fachá. Celkově mě bohužel instalace Firefoxu 2.0 posunula zpět a nikoliv dopředu. Radím tedy počkat s instalací nového Firefoxu ještě pár dní, než budou Vaše oblíbená rozšíření kompatibilní. Snad to bude brzy.

Komentáře

25. 10. 06, 16.22

A to jsem to chtěl udělat včera … občas ta lenost není na škodu :-0

2. terbi
25. 10. 06, 16.24

ak sa nemylim, tak Firefox 2.0 podporuje sessions nativne a namiesto Screen Grab, kt. vyzaduje javu mozes pouzit Pearl Crescent Page Saver href=„http://­pearlcrescent­.com/products/pa­gesaver/“ rel=„nofollow“>http:/­/pearlcrescen­t.com/products/pa­gesaver/

25. 10. 06, 16.25

No taky mne to štve!! Ale ještě víc mně štou lidi co kritizujou FF za doplňky. Prý je to takový „slož si sám“, slýchávám dost často od uživatelů Opery.

4. Petr
25. 10. 06, 16.30

No instalovat zatím neoveřenou verzi, i když už oficialni, je risk sám o sobe ;) Zvlaste u opensource to plati dvojnasob ;)

25. 10. 06, 16.32

Mě osobně teda rozšíření fungují… a že se s nimi nežinýruji.

Adblock, AutoCopy, ColorZilla, FireBug, ForecastFox, HTML validator, IE tab, inspect this, Pearl Crescent Page saver (screenshoty stranek), Web developer…
A vsechny jdou…

Testoval jsi RC3 ?

25. 10. 06, 16.32

V podstate mam stejny problem, ovsem (pr me nezbytne) All-in-one Gestures jsou jiz ve verzi pro FF 2.0, tak i par dalsich jako del.icio.us extension ci Adblock, na ostatni pockam.

Zprvu me zmatlo, ze v Tools menu jsou Extensions prejmenovany na Add-ons, ovsem link v Add-ons menu zni postaru ‚Get Extensions‘. Trochu zmatek.

7. tom
25. 10. 06, 16.53

SessionSaver rozhodne nepotrebujete. Ukladanie sessions je jedna z noviniek. Takisto ukladať screeny určite pôjde iným rozšírením. Nevidím teda u Vás reálny dôvod na kritiku FF2.

25. 10. 06, 17.44

Ta kompatibilita je jedním z těch nejvetších problému pro aktualizace Firefoxu, nezbývá než děkovat za Operu :-).

25. 10. 06, 17.46

Můžeš zkusit nainstalovat Mr. Tech Local install a povolit kompatibilitu všech rozšíření.

To je asi tak zatím jediná pomoc proti nekompatibilním rozšířením.

PS: Kua ta kontrola pravopisu je ale děs. Aspoň mě to naučí psát česky.

10. Pitel
25. 10. 06, 17.49

Zkus nightly tester tool… ja jedu na 2.0 uz od prvni bety, a s timhel rozsirenim na rzsireni celkem no problem :)

http://users.blueprintit.co.uk/…efox/nightly

11. Jirka
25. 10. 06, 18.09

Hm, s Operou tyhle umělé „problémy“ opravdu neřeším… ;-D

12. miki
25. 10. 06, 18.17

než autori rozšírení upgraduju svoje rozšírenie, môžeš ich sfunkčniť „po domácky“. Ako sfunkčniť rozšírenia…

13. Acci
25. 10. 06, 18.58

Většina rozšíření je již právě aktualizovaná, SessionSaver již není potřeba a ScreenGrab href=„http://­andy.5263.org/scre­engrab/“ rel=„nofollow“>http:/­/andy.5263.or­g/screengrab/ je aktualizován také (bohužel není uveden na webu Firefox Add-ons).

[5] RC3 byl prohlášen za finální Firefox 2, tedy je naprosto totožný.

[6] Není to zmatek, Add-ons (v češtině Správce doplňků) obsahuje totiž jak rozšíření, tak i motivy vzhledu.

[7] Ano, protože v Opeře tyhle věci ani nejsou

14. bukaJ
25. 10. 06, 19.03

Vyčkat se vyplatí. Vždycky okouknu nejdůležitější rozšíření, než instaluju FF. Když není zbytí, lze většinou rozšíření upravit, aby instalovat šla – alespoň u minoritních změn – pokoušet tohle na 1.x vs. 2.x raději nebudu :-)

25. 10. 06, 19.17

MR Tech Local Install href=„https:/­/addons.mozilla­.org/firefox/421/“ rel=„nofollow“>https:­//addons.mozi­lla.org/firefox/421/
mi spoustu (pro mne důležitých) rozšíření rozeběhl – a já nepoznám rozdíl – snad vyjma jmenovaných pozitiv. Prohlížeč mi zatím ani jednou nespadl (ač by na to při mém zacházení měl jistě nárok tak 5× denně :-)

Ano, Firefox je tak trochu pro kutily. Ale nevadí mi to – naopak, jsem spokojen a šlape tak jak má a jak potřebuji.

Třeba odkazované rozšíření pomůže ostatním nedočkavcům, jako jsem byl já. A Firefox Portable 1.5 na USB disku to jako záloha pro případ nouze jistí ;-)

16. VfB
25. 10. 06, 19.30

pro mně je velkým lákadlem kontrola pravopisu, kterou si nemůžu už za tu chvilku vynachválit
extensions mi fungují téměř všechny, jen pro deicio.us je to nové rozšíření takové „humpoláčtější“ a ještě mi nefunguje aavark (nebo jak se tojmenuje, dlá kolem prvků stránky červené rámečky s popiskami co je co, ale to se dá asi nahradit něčím z developer toolbaru)

25. 10. 06, 20.21

Asi jsem natvrdlej.. jak se tedy dá ve FF nastavit, aby ukládal aktuální konfiguraci panelů při ukončení prohlížeče, aby se nahrála při dalším startu?

18. tom
25. 10. 06, 20.37

Hneď na prvej karte FILE->PREFERENCES->MAIN:
When Firefox starts: Show my windows and tabs from last time.

25. 10. 06, 20.53

Wow :-), tak to jsem fakt přehlídl :-)

20. r34ktor
25. 10. 06, 21.02

Nástroje->Možnosti->Hlavní->Při startu aplikace Firefox: Zobrazit okna a panely z minula

25. 10. 06, 21.03

Zlatá Opera :)

22. OttY
25. 10. 06, 22.04

http://www.mozilla.sk/…ester-tools/
http://www.mozilla.sk/…cal-install/

Alebo manuálne úpravou súboru install.rdf v archíve XPI (položka maxversion).
Alebo všeobecne pre všetky rozšírenia:
Otvoriť about:config a pridať do neho Nový reťazec s názvom app.extension­s.version a zadať jeho hodnotu na nižšiu verziu Firefoxu. Napríklad ak sa používa 1.5.0.7, tak tam dať hodnotu 1.5 a potom sa dajú nainštalovať všetky rozšírenia, ktoré sú kompatibilné s verziou Firefoxu 1.5. Najistejšie to ale bude tými rozšíreniami.

23. Mark
25. 10. 06, 23.08

S rozšířeními jsem mel problém v době, kdy jsem testoval RC vývojové verze Firefoxu 2.0 . S nástupem stabilní 2.0 se rozšíření ještě ten den aktualizovala, a fungovalo to v klidu.

btw, koukám že místní Operáci ve své hlouposti totálně vybuzení :-), vidí článek který popisuje možný problém, kterému sice ani zbla nerozumí, ale už už musí naklusat jak stádo oveček a poslušně hlásit svoji příslušnost :-)))) … jak malý děti. Opera žádná rozšíření nemá, jistě, tomu říkám výhra :-))

24. tom
26. 10. 06, 00.00

Práve na digg vyšiel odkaz na zaujimavý článok o tweakovaní FF2. Ak v about:config doplníte string extensions.chec­kCompatibility a nastavíte ho na true FF2 nebude kontrolovať verziu extension. Ak to funguje, pôjde o jednoduchší spôsob ako u každej extension prepisovať maxversion.
Zdroj: http://www.tweakguides.com/Firefox_9.html
Inak súhlasím s Markom ohľadne fandov Opery. Chcel by som vidieť čo používajú miesto Web developer, JS debuggera (Firebug). Kto sa seriózne zaoberá webdesignom používa FF. Na brúzdanie netu je samozrejme dobrá (skvelá) aj Opera. BACK je stále v Opere rýchlejší ako v FF.

25. tom
26. 10. 06, 00.04

Keď už som v tom FF ošiali. Ak vám vadí, nefunkčnosť BACKSPACE ako BACK potom vás bude zaujímať toto:
http://forums.mozillazine.org/viewtopic.php?…

26. Mathias Kodlodot
26. 10. 06, 01.08

Ale jo Opera, ma rozsireni (Developer Toolbar, atp.), ale ted zrovna tohle pisu ve Firefoxu 2 :-)

26. 10. 06, 06.24

[21] Přesně. Jak by možná řekl RH. Proč se „otravovat“ s Firefoxem a jeho pluginy, když tohle vše má Opera už v základu :)

Ale asi je to o zvyku, tak raději nebudu rýpat :) Já FF otevírám pouze při ladění a jsem tomu rád.

28. Acci
26. 10. 06, 08.59

[27] Typická RH demagogie ;)

26. 10. 06, 08.59

Operu jsem taky musel narvavat abych z ni mnel uzitecny prohlizec a stejne se mi nelibi.
FF podle mne neni sloz si sam. Ja pouzivam asi 10 rozsireni z toho tam uz bylo myslim 6.
FF ma vsechno co bezny uzivatel potrebuje. A FF2.0 toho ma jeste vic.
Ondra

30. VfB
26. 10. 06, 11.25

obyčejný surfer (který nevyrábí weby či se nezabývá seo) si bez problémů vystačí s čistou versí FF, popřípadě, že radikálněji využívá bookmarx, tak s nějakým rozšířením pro delicio.us či podobný systém

31. Honza M.
26. 10. 06, 12.47

Náhodou nepřítomnost rozšíření v Opeře je výhra :)

32. dgx
26. 10. 06, 21.04

Jde vám Firefox vypnout? Mě zůstane viset v úlohách.

33. Acci
28. 10. 06, 20.02

[32] I v Safe módu nebo s novým profilem?